TriCaster VT[5] Hardware RS-8

What is causing my RS-8 to lock up?

One customer was experiencing intermittent lockups with the RS-8, and it turned out to be a defective powered USB hub. As the RS8 consumes the upper limit of USB power, (500mA), buy a good named manufacturer and make sure the hub is capable of supplying the juice required.


Has my RS-8 been patched?

If you put the RS-8 into test mode (holding down PGM 2, 4, 6, and 8 while plugging in USB) the patch will indicate it is running by PGM 3 blinking.


After upgrading to version 4.6, I noticed my RS-8 buttons are not as bright; why?

NewTek made a change to the driver; this is intentional.


It seems I can use either my mouse or my RS-8, but not both at the same time; why?

The problem is almost certainly that the RS-8 is mapped as a serial port. Some older mice (or perhaps older drivers) might try to act as serial devices as well, which they should not. The best way to solve this would be to go into the XP Device Manager and look at which port the USB Serial port (RS8) is mapped to, then set the RS8 preference setting to look specifically at this port. At this point it will not need to scan the ports (which is where the conflict is arising from.)

The problem here is that the mouse driver is allowing it’s port to be opened by VT, when it really should not allow this.


No one is touching the switcher, but it will perform an auto all by itself! Why?

One installation at a church was having this problem, and eventually realized the talent was turning the microphone on and off from the mic's power switch, apparently sending a spike into the SX-8. Threats of pain and duct tape seem to remedy that persons' bad habit.


I just upgraded and my RS-8 is not being seen now by VT[4].

Open up the preferences and scroll down until you get to the Switcher category.

Under Switcher surface connected is by default set to Not connected to computer.

Use the drop down list to select Automatically detect RS8.

Close the Preferences and restart VT.